LinuxSIS

LinuxSIS 5.5.5 เปิดให้ Download แล้ว

แผ่น CD SIS 5.5.5


 

ขณะนี้ ทีมพัฒนา LinuxSIS ได้จัดทำ LinuxSIS รุ่น 5.5.5 เสร็จสมบูรณ์ และนำขึ้นให้ Download แล้วครับ

LinuxSIS รุ่น 5.5.5 นี้ เป็นรุ่นที่ปรับปรุงแก้ไขปัญหา และ update บางส่วน จาก LinuxSIS 5.5 ตัวเต็ม

สิ่งที่ปรับปรุงแก้ไข หลักๆ ก็คือปรับปรุงตามที่ระบุไว้ใน http://wiki.opentle.org/SIS-Upgrade-Bugfix ในส่วนของ 5.5 ครับ

ดังนั้น ท่านที่ใช้ 5.5 อยู่แล้ว ก็สามารถ upgrade ได้ตามหน้า http://wiki.opentle.org/SIS-Upgrade-Bugfix และเมื่อเสร็จแล้ว ให้สั่ง apt-get dist-upgrade เพื่อ upgrade จาก 5.5 เป็น 5.5.5 ครับ

ท่านสามารถ Download ทดลองใช้ได้ที่ หน้า Download

ท่านสามารถรายงานปัญหาได้ที่ http://bugs.opentle.org/

สอบถามหรือต้องการให้เพิ่มเติมเรื่องอะไรแนะนำเพิ่มเติมได้ที่ http://www.opentle.org/th/forum/32

สำหรับท่านที่สนใจรายละเอียดความเป็นมา และสิ่งที่ได้ปรับปรุงแก้ไขไปจากรุ่น 5.5 กรุณาหาอ่านได้ในหน้าโครงการลินุกซ์ซิส ใน Wiki ของ opentle ครับ หรือ ที่นี่ ครับ

ขอบคุณหินกับโอ้ สำหรับผลงานดีๆ ที่ทำให้พวกเราใช้กันครับ ;)

อัพเกรด php ในลินุกซ์ซิส 5.5

เนื่องจาก php 5.2.2 ที่ลินุกซ์ซิส 5.5 ใช้งานอยู่นั้น มีผู้พบข้อผิดพลาดในการใช้งานฟังก์ชันบางฟังก์ชัน ทางทีมงานจึงได้ทำการอัพเดทแพ็กเกตของ php ให้ใหม่ขึ้น

ขั้นตอนการอัพเกรดสามารถทำได้ที่ http://wiki.opentle.org/SIS-Upgrade-Bugfix#php

Upgrade คู่มือ LinuxSIS 5.5 ครับ ในส่วน Web Server ครับ

ก่อนอื่น ต้องขออภัยผู้ใช้งาน LinuxSIS ทุกท่านที่คู่มือของ LinuxSIS 5.5 ในส่วนนี้ไม่มีรายละเอียดที่ชัดเจนครับผม

ที่มา

เนื่องจากมีผู้ถามเกี่ยวกับการทำ Web Server โดยใช้ LinuxSIS มาพอสมควร โดยมีคำถามกลุ่มหนึ่งไม่เข้าใจเรื่องระบบ Web Site ของผู้ใช้ (Web Site ส่วนตัว ไม่ใช่ Web Site หลัก) ซึ่งผมได้เคยแนะนำไปแล้วหลายครั้ง

Patch สำหรับติดตั้งและปรับแต่งระบบตรวจสอบ Virus-Spam ให้กับ Mail Server สำหรับ LinuxSIS 5.0

Feature นี้ เป็น Feauter หนึ่งที่ SIS 5.0 ระบุว่าจะมี แต่ก็ยังไม่ได้ทำซะที อาจจะเพราะรีบออก ก็เลยไม่ได้ทำ แถมไม่มีคนทวง ก็เลยไปกันใหญ่ แต่อย่างไรก็ดี Feature นี้ก็ได้ทำจนเรียบร้อย (จนได้) ใน LinuxSIS 5.5

ตอนนี้ เราได้ทำ patch ให้สำหรับเครื่อง mail server ที่ยังใช้ SIS 5.0 ได้นำไปใช้กันครับ patch แล้ว ได้ไม่ได้อย่างไรก็รบกวนแจ้งผลด้วยครับ ถ้ายังมีปัญหา ก็จะได้นำมาปรับปรุงแก้ไขต่อไปครับ

รายละเอียดเชิญที่ http://wiki.opentle.org/SIS5-patch เลยครับผม :)

Upgrade LinuxSIS

สำหรับผู้ที่ใช้ LinuxSIS 5.5 Beta นะครับ

ถ้ายังไม่ได้ใช้งานอะไรมาก ผมแนะนำให้ติดตั้งใหม่ดีกว่าครับ เพราะว่า upgrade แล้ว Antivirus ที่ปรับแต่งให้ทำงานกับ mail server น่าจะใช้งานไม่ได้นะครับ

แต่ถ้าใช้งานอยู่แล้ว มีข้อมูลมากจนไม่อยากลงใหม่ ตอนนี้มีวิธีแนะนำ 2 วิธีครับ

1. Upgrade ตรงๆ

1.1 เข้า Webadmin แล้วเปิด firewall ให้พอร์ต ftp (20 และ 21) ให้ผ่านได้

1.2 login เป็น root

1.3 สั่ง apt-get update

1.4 สำหรับ Beta 2

1.4.1 apt-get --fix-broken install แล้วมันจะถามให้กด Y

1.4.2 apt-get upgrade แล้วมันจะถามให้ติดตั้งโปรแกรมหลายตัว ให้ตอบ Y แล้วรอติดตั้ง

1.4.3 apt-get install webadmin แล้วมันจะถามให้ติดตั้งโปรแกรมหลายตัว ให้ตอบ Y แล้วรอติดตั้ง

1.4.4 ที่สำคัญที่สุด ห้าม สั่ง upgrde clamav โดยเด็ดขาด ไม่งั้น หลุดหมดเลยครับ (ยังหาทางแก้ไม่ได้)

เปิดให้ download แล้ว SIS5.5 final

LinuxSIS 5.5 ฉบับสมบูรณ์ ได้เปิดให้ Download แล้ว โดยท่านสามารถ Download ทดลองใช้ได้ที่ หน้า Download

ท่านสามารถรายงานปัญหาได้ที่ http://bugs.opentle.org/

สอบถามหรือต้องการให้เพิ่มเติมเรื่องอะไรแนะนำเพิ่มเติมได้ที่ http://www.opentle.org/th/forum/32

ขอต้อนรับสู่โลกของ Server หุหุหุ

 

Syndicate content Syndicate content