ติดตั้งไดรว์เวอร์ canon pixma ip 1880 ไม่ได้ครับ

อนุวัตร
รูปภาพของ อนุวัตร
User offline. Last seen 6 years 40 weeks ago. ออกไปแล้ว
10
Joined: 22 มิ.ย. 2007
Points: 12
ผมซ้ือเคร่ืองพิมพ์มาใหม่ของ canon pixma ip 1880 แต่ยังติดตั้งใช้งานไม่ได้เลยครับ ขอความช่วยเหลือด้วยครับ ขอขอบคุณล่วงหน้าครับ




ขอบคุณครับที่ให้โอกาส

taz
รูปภาพของ taz
User offline. Last seen 1 ปี 9 weeks ago. ออกไปแล้ว
1300
Joined: 2 ธ.ค. 2002
Points: 2111
เท่าที่ลอ

เท่าที่ลอง search ดูมีพูดถึง driver จากเว็บ cannon เองเลย

เค้าบอก load มาจาก http://www.canon.com.sg/

แต่ผมลองเข้าไปดูละ มันเป็น .rpm ใช้กับ tle ไม่ได้ ไม่แน่ใจว่า ใช้ alian แปลง pkg แล้วจะใช้ได้หรือเปล่า อันนี้ต้องลองดูเองครับ

 วิธี test http://ibr94.blogspot.com/2007/08/canon-pixma-ip1880-printer-in-ubuntu.h...





=Read The Fxxx Manual _| ̄|○

Don't Learn to HACK - Hack to LEARN

ถ้าไม่รู้ว่า RTFM คืออะไรให้ไปอ่าน ถามอย่างไรจึงจะได้คำตอบ

อนุวัตร
รูปภาพของ อนุวัตร
User offline. Last seen 6 years 40 weeks ago. ออกไปแล้ว
10
Joined: 22 มิ.ย. 2007
Points: 12
ขอขอบคุณมากครับผมที่ช่วยค้นหาให้
อขอบคุณมากๆครับผมที่ช่วยค้นหาให้




ขอบคุณครับที่ให้โอกาส

mkk2529
รูปภาพของ mkk2529
User offline. Last seen 2 years 21 weeks ago. ออกไปแล้ว
10
Joined: 11 ก.ย. 2007
Points: 20
ผมทำตามนี้แล้วปริ้นได้ครับ linux 9.0 ตามที่ท่านtazว่าครับ

First step installation, download the files from canon server :
Go to http://www.canon-asia.com/index.jsp?fuseaction=support&prod_type=bj&country=SG
select the Model PIXMA iP1880 and Menu Drivers & Softwares
Choose the version 2.7.0 for Linux
Download only the two files which are "Common package" and "Package for the iP1800series"

The files are in RPM. So we need to convert it to Ubuntu packaging format.
Second step :
Install the alien package by command

sudo apt-get install alien

Convert it to .deb
sudo alien -k cnijfilter-common-2.70-1.i386.rpm
sudo alien -k cnijfilter-ip1800series-2.70-1.i386.rpm

Install it
sudo dpkg -i cnijfilter-common_2.70-1_i386.deb
sudo dpkg -i cnijfilter-ip1800series_2.70-1_i386.deb

Other than those files, you need some old library to support it like libtiff3 and libpng3. I can't find the libtiff3 on the repository so I make softlink to point libtiff3 to libtiff4. Without this installation, you won't be able to print anything.

cd /usr/lib/
sudo ln -s ./libtiff.so.4.2.1 ./libtiff.so.3

for libpng3, install from repository
sudo apt-get install libpng3

After you install above command successfuly, we go to
Step 3
Turn on the printer and connect the USB to the printer.
Open the printing from System->Administration->Printing
Double click the new printer
Select Printer Type " Local or Detected Printer"
Select a Detected Printer : Canon iP1800 series ......
Then go to the next page
I can't find the iP1800 on the list, so I select the "Install Driver" button and point to
/usr/share/cups/model
and select canonip1800.ppd
Go to the next page and press the apply button.
You will see on the Printers window, there will be iP1800 icon on it. You can make it default printer by right click and select "Make Default"
This part, voila, you are ready to print!

For the Hardy users, you should install libgtk1.2 and libxml1 and no need to go to step 3.
sudo apt-get install libgtk1.2
sudo apt-get install libxml1

After turn on the printer, there will be popup to install the printer.

การแปลงไฟล์ จาก rpm มาเป็นdeb ให้นำไฟล์ที่โหลดมาได้มาไว้ที่ บ้านของทะเลuser (home)

สำหรับลินุกซ์9 (ubuntu 7.10 8.04 ต้องลงตัวสุดท้ายนี้ด้วยนะครับ

sudo apt-get install libgtk1.2
sudo apt-get install libxml1

เพราะผมลงเสร็จแล้วไม่ได้ลงสองตัวนี้สั่งพิมพ์ไม่ออกมาเลยครับ

Syndicate content